The X-Windows Interactive Navigation Data Editor

G. C. Rinker
Navigation Systems Section

A new computer program called the X-Windows Interactive Data Editor (XIDE) has been developed and demonstrated as a prototype application for editing radio metric data in the orbit-determination process. The program runs on a variety of workstations and employs pull-down menus and graphical displays, which allow users to easily inspect and edit radio metric data in the orbit data files received from the DSN. The XIDE program is based on the OSF/Motif (Open Software Foundation) Graphical User Interface (GUI) and has proven to be an efficient tool for editing radio metric data in the navigation operations environment. It has been adopted by the Magellan Navigation Team as their primary data-editing tool. Because the software was designed from the beginning to be portable, the prototype has been successfully moved to new workstation environments. It has also been integrated into the design of the next-generation software tool for DSN multimission navigation interactive launch support.

1. Introduction

The fundamental software system used for spacecraft navigation at JPL is the Orbit Determination Program (ODP). This program, which actually consists of a sequence of integrated programs, is currently being used to support NASA deep space missions and also provides launch support for other domestic and international missions. One of the critical steps in the orbit-determination process is editing radio metric data. The X-Windows Interactive Data Editor (XIDE) is a new computer program developed as a prototype to enable navigation operations personnel to perform more efficiently in a workstation environment. Figure 1 shows an overview of the XIDE input and output relative to the ODP. The overview begins with the radio metric data that are delivered from the DSN stations through the Ground Communications Facility (GCF) to the DSN Navigation Facility, within the Network Operations Control Center (NOCC), where it is converted by the Radio Metric Data Conditioning (RMDC) team into an orbit data file (ODFILE) for input into the ODP.

The primary function of the orbit-determination process is to estimate the spacecraft trajectory and other relevant parameters by using the processed ODFILE provided by the RMDC team. The ODP includes a complete set of algorithms necessary to model the radio metric observations and the motion of a planetary orbiter or deep space probe [1]. The program is capable of estimating the spacecraft trajectory and associated parameters by using either weighted least-squares or batch-sequential estimation algorithms.

At the heart of the estimation process, which is frequently referred to as “fitting” the data, are the residuals; for each measurement (such as Doppler or range), the residual consists of the difference of the observed value and the computed (predicted) value of the measurement. The
ODP produces a file of before-the-fit residuals, called a REGRES file, and a file of after-the-fit residuals, called a PRESID file. These residuals are the tools that navigation-operations personnel use to assess the quality of the radio metric data and the accuracy of the mathematical models used for trajectory estimation and propagation for a particular spacecraft.

It is at this stage, when the residuals are available, that the orbit-determination analyst (or radio metric data-conditioning analyst) edits the radio metric data by removing data that have unusually large measurement errors or by removing data for which the mathematical model is clearly incorrect, and then the data are fit to obtain an improved solution. The complexity of the navigation system, including measurement, data processing, and communication components makes editing radio metric data a difficult task. Success depends on the skills of the analyst, who relies on his or her experience to solve complex problems in system development and operations for navigation [2]. Navigation operations have yet to become a routine set of procedures. When the data editing has been completed by the analyst, the result is a set of delete commands that are then used in the ODP to update the orbit estimate until finally a best-trajectory estimate in the form of a PFLE is produced.

This article traces some of the significant concepts in the development of the XIDE program and shows some of the interactive features that have made it useful. However, it is neither a tutorial introduction to the subject, nor an XIDE user's guide. Illustrations of the menus and displays generated by XIDE are included, and even though their contents are not described completely, it is hoped that the reader can appreciate how the XIDE GUI helps to streamline the orbit-determination process.

II. Program Development

The availability of workstations with high-resolution bit-mapped displays and pointing devices for navigation software development, and the introduction of such hardware into the navigation-operations environment, have made it possible to exploit these capabilities. The advent of new windowing software, such as the X Window System (referred to colloquially as X-Windows) gives the developer the power to present a detailed graphical display to the user and then allows the user to interact with it.

The first operational navigation application to move in this direction is XIDE, which was developed as a prototype to demonstrate how GUI technology can improve the productivity of navigation operations personnel. This program is the first navigation application at JPL to fully exploit the advantages of a modern workstation environment. There was a predecessor of XIDE, called IDE (Interactive Data Editor), which identified the basic concept; however, the GUI development for the workstation environment is completely new and has evolved as a cooperative effort between programmers and users.

One of the underlying goals in applying the GUI technology to a navigation application was to select a software-development strategy that would provide software portability and vendor independence. The strategy selected was based on the X-Window System, which is a network-based graphics windowing system. It was developed at the Massachusetts Institute of Technology (MIT) and has been adopted as an industry standard [3]. X-Windows provides the bare bones of a windowing system upon which almost any style of GUI can be built. One of the most popular user interfaces currently available is the OSF/Motif GUI, developed by the Open Software Foundation [4], which was adopted for software development to maximize portability.

The primary design goal for XIDE was ease of use. Based on demonstrations of XIDE, the learning curve for this program was found generally to be small, and almost nonexistent for users who have had to edit radio metric data and have used a computer with a GUI, such as a Macintosh. Users report that it takes about fifteen minutes to learn to operate the basic features of XIDE. Since all the options are represented graphically on-screen, almost no keyboard input is required (although advanced users can use it as a shortcut) because users can point and click with a mouse at the functions to be performed. To delete a data point, users simply point at the one they want to eliminate or draw a lasso around groups they want to erase. If the user wants to change the numeric scale that is used to display the data, there are a variety of ways to do this easily.

The other major design goal for XIDE was speed. Because the program is very interactive, users immediately see changes in the residual plot as they delete the data on-screen. They can iteratively select, delete, and undo deletes until the data set is satisfactorily edited. XIDE will then quickly write out a set of accurate delete commands that are executed by an ODP link when desired.

Users of XIDE have developed a second unexpected use of the application. Instead of being used solely to edit data, the program is often used simply to view and print residual plots. With XIDE's scaling and labeling capabilities, users can get a plot to appear with the desired
content on-screen before having to print it out. Then all a user needs to do is use the button labeled Print to get a hard copy.

III. Program Usage

This section gives an overview of the functions that XIDE can perform. The functions will be described in terms of an operational scenario, the basic GUI features, and the advanced GUI features.

A. Operational Scenario

A walk-through of a basic data-editing session follows: The user first sees the top-level window, as shown in Fig. 1. This consists of a menu-bar at the top, an interactive plotting area in the middle, and a message area at the bottom. By dragging the mouse, with the left button down, across the menu-bar, each of the main pull-down menus is displayed to give the user a quick overview of the program capability and organization. The menus that are displayed in this fashion are shown in Figs. 2, 3, 4, 5, and 6 and are discussed in more detail below.

The next step is to pull down the File menu, which actually appears as shown in Fig. 7. One of the features that makes this type of GUI easy to learn is that menu items that are not reasonable at this stage are grayed-out. This means that they are are both visually and functionally disabled as a choice for the user. As shown in Fig. 7, at this stage all the File menu items are grayed-out except for the Open and Exit selections, since they are the only reasonable choices. On the right-hand side of the menu are the optional keyboard accelerators; for example, the keyboard combination Meta-O will select the Open item, if the user prefers to use this rather than mouse input.

In this case, when the user selects the Open item, a dialog box pops up, as shown in Fig. 8. This file-selection dialog box allows the user to move through the file-directory tree to identify the specific REGRES or PRESID file from the ODP that is to be opened for editing. Once the data file is selected, and if it is of the acceptable file type, then the Open New File dialog box is immediately replaced with a Data Set dialog box, as shown in Fig. 9. The user is presented with a complete and detailed list of the available data and can then select with the mouse the data set to be plotted from those available on the specified input file. A residual plot is then immediately displayed. After using the mouse to identify some "bad" points and then using the pull-down menus to Cut and then to Center Scale, the resulting plot of the residual data is displayed as shown in Fig. 10. The horizontal scale is time, labeled for year, month, day, hour, minute, and second, and the vertical scale is residual value, labeled for the data type and data band (uplink/downlink). The data shown in Fig. 10 are for the Magellan spacecraft, specifically the two-way S-band Doppler data before-the-fit from August 15, 1990 at 09:00:00 UTC to August 17, 1990 at 07:00:00 UTC.

One can then edit other data types, such as the two-way minus three-way Doppler data, and if ODP delete commands are desired for this session, then the Save As command under the File menu can be selected. The resulting pop-up dialog box is shown in Fig. 11. One noteworthy item is that the delete-command format can be used for the ODP or the Orbit Data Editor (ODE). The ODE format is provided so that this tool, or one of its offspring, could be used by the DSN RMDC team and would potentially benefit all flight projects in the pre-ODP data-conditioning phase. After the user specifies the delete-command information (a file name is sufficient), then the delete commands are written in an intelligently compressed format to a text file, as shown in Fig. 12. These delete commands can then be used to update the spacecraft-orbit estimate with the ODP and finally generate an improved trajectory estimate, as shown in Fig. 1.

B. Basic GUI Features

The basic GUI features are accessed through the menu-bar, as shown in Fig. 1. The menu-bar consists of five pull-down menus: File, Edit, View, Options, and Help. The File menu (Fig. 2) allows the user to perform global input and output operations. This menu provides the capability to open a new data set (for the current input file), open a new input file, save the delete commands as a text file, print a hard copy of the current plot, or exit from the program.

The Edit menu (Fig. 3) contains high-level functions used to edit the data. This menu provides the capability to cut (delete the currently selected) points, remove (delete) points that are off-scale for the current plot, select around periapsis (point of lowest altitude for planetary orbiters, such as Magellan), or undo (in reverse order) the previous delete operations.

The View menu (Fig. 4) allows the user to easily change the way that the data are displayed in the plot, primarily the plot scale. This menu provides the capability to refresh the plot, change the plot scale interactively, automatically select a scale to center the data in the plot, switch to the default scale, or perform a median absolute-deviation scaling operation.
The Options menu (Fig. 5) allows the user to change more details about what is displayed and how the program behaves. This menu provides the capability to change the plot label, change the plot symbols used for different stations, toggle the display of mean and sigma lines on the plot, change the behavior of the lasso, or change the trajectory file (PFILE) for periapsis computation.

The Help menu (Fig. 6) provides additional on-line information for the user about how to use the program and its features. This menu provides additional text information on the purpose of the program, how the menus are structured and how they operate, and on the current version of XIDE.

C. Advanced GUI Features

In addition to the basic GUI capability provided by XIDE, there are several advanced GUI features that deserve special mention: the lasso feature, the plot-scale widget, and the magnifying glass.

The most frequently used advanced feature is the ability to lasso data points to be deleted with the mouse. Figure 13 shows an entire workstation screen with the XIDE window in the front. The residual plot is differenced (two-way minus three-way) Doppler data for the Magellan spacecraft from August 15, 1990 at 13:00:00 UTC to August 17, 1990 at 01:00:00 UTC. There are clearly some bad points in the lower half of the residual plot. These could be deleted one at a time by using the mouse to point at each and then clicking the left button. In fact, when this is done, the individual point changes to a plus symbol, and the color changes to red, which indicates that the point has been selected for deletion. At any time, the Cut menu item, or equivalently the middle mouse button, can be used to actually delete the points that have been selected; this causes them to disappear from the plot. Conversely, they can be returned to the plot by using the Undo menu item in the Edit menu.

A much more powerful concept for deleting a group of points is to select them with the lasso. By holding down the left mouse button and dragging the cursor across the plot, a curve of any reasonable shape can be drawn (for example, three quarters of a circle as shown in Fig. 13). When the left mouse button is released, an imaginary line is drawn between the two endpoints, and all the points inside the curve are selected (i.e., they change to a red plus symbol), and they can then be cut from the plot with the middle mouse button. The lasso is probably the single most effective feature of the XIDE program.

The second most important advanced feature is the Change Plot Scale dialog box (Fig. 14). This feature is implemented as a widget, which means that it is a GUI component that is reusable by other programs. This is not the only paradigm for changing the plot scale but it is an acceptably powerful one. As shown in Fig. 14, a miniature version of the residual plot is displayed. There are bars extending beyond the edge of the plot, two horizontal and two vertical. By using the mouse to touch one of these four bars with the cursor, the user can grab that bar by pressing the left mouse button, then drag the bar to the new desired location on the miniature plot, and then release the mouse button. As this is done, the appropriate numeric values are dynamically updated to reflect new minimum and maximum values of the x-axis date and time and the y-axis residual scale, which are displayed below the miniature plot. Also, the bars can only move in the appropriate horizontal or vertical direction and are bounded by the edge of the miniature plot. When the user has finished focusing on the data of interest, the Done button will return to the original plot (for example, as shown in Fig. 10); however, the new minimum and maximum values, which were selected without touching the keyboard, will be used for the residual plot.

The last advanced feature to be mentioned is the magnifying glass, shown in Fig. 15. In this case, the data set is two-way S/X-band Doppler data for the Ulysses spacecraft from January 9, 1991 at 00:00:00 UTC to April 25, 1991 at 00:00:00 UTC. As indicated by the label at the top of the plot in the XIDE window, there is a total of 4,402 after-the-fit points, and only those points used to construct this new orbit solution are displayed. When there are numerous such points, the fine structure of the data (for example, station dependency) can be quickly examined by pressing the right mouse button. A small square then appears on the plot where the cursor is, and a corresponding Zoom window with an expanded scale appears in the top-left corner of the screen. This window operates like a magnifying glass and follows the cursor as long as the right mouse button is pressed.

IV. Program Testing

The XIDE program was first used by the Magellan Navigation team, which possessed the prerequisite workstations. The team members must generate an estimated trajectory for Magellan on a daily basis, and they have been using XIDE operationally since the beginning of 1991; they use XIDE to edit radio metric data in the form of RGBR or PRESID files and produce delete commands for the ODP. The team members responsible for radio metric data editing estimate that by using XIDE, they have
reduced by 75–90 percent (from 4 hr to between 0.5 and 1.0 hr) the amount of time spent on these functions on a daily basis, as compared with the previous procedures used by the team on the UNISYS mainframe computer.

One of the important facets of testing the XIDE program was, in fact, demonstrating the portability of the source code. The XIDE program was developed from the beginning with this characteristic as one of the goals. Consequently, it was ported with relatively few changes from the original Sun UNIX environment to a Hewlett-Packard UNIX environment, and even to a DEC (Digital Equipment Corporation) VAX/VMS environment, while maintaining the same GUI from the user's viewpoint and essentially the same source code from the programmer's viewpoint.

The DSN Multimission Navigation team has been using the Pack Solve Analyze (PSA) program to perform DSN launch-support operations for several years [5]. This software is currently being used in a dedicated minicomputer environment based on the High Earth Orbiter (HEO) multimission navigation concept [6]. Because of the development and demonstrations of the XIDE prototype software in the workstation environment, the DSN Multimission Navigation team has incorporated XIDE directly into the design of their second-generation interactive orbit determination package.1

V. Conclusion

The development of the XIDE program has proven to be successful from several perspectives. It was possible to integrate an existing navigation application with a GUI, specifically the OSF/Motif libraries, while still maintaining source-code portability. Once the prototype had matured to the point where it needed to be demonstrated, it was used experimentally in navigation operations by Magellan, an existing flight project, and ultimately was adopted as an operational tool. Finally, it was incorporated directly as an advanced capability into the design of the next generation of launch-support software for DSN multimission-navigation operations.

Acknowledgment

The author would like to thank Eric Slimko for providing the programming creativity to make the GUI for the XIDE program a reality while he was temporarily a member of the Navigation Software Development Group.

References


Fig. 1. X-Windows Interactive Data Editor overview.

Fig. 2. File menu.

Fig. 3. Edit menu.

Fig. 4. View menu.

Fig. 5. Options menu.
Fig. 6. Help menu.

Fig. 7. File menu with some items grayed-out.

Fig. 8. Open New File dialog box.

Fig. 9. Data Set dialog box.
Fig. 10. Magellan Doppler residuals before the fit.
Fig. 11. Write Delete Cards dialog box.

DELETE (F2MF3) BAND (X) FROM (90/08/15,14:50:29.9) TO (90/08/15,17:05:30.1) DSN (61).
DELETE (F2MF3) BAND (X) FROM (90/08/15,21:22:29.9) TO (90/08/15,22:50:30.1) DSN (45).
DELETE (F2MF3) BAND (X) AT (90/08/15,23:46:30.0) DSN (45).
DELETE (F2MF3) BAND (X) AT (90/08/15,23:49:30.0) DSN (45).
DELETE (F2MF3) BAND (X) AT (90/08/15,23:52:30.0) DSN (45).
DELETE (F2MF3) BAND (X) FROM (90/08/15,23:54:29.9) TO (90/08/15,23:55:30.1) DSN (45).
DELETE (F2MF3) BAND (X) FROM (90/08/16,00:25:29.9) TO (90/08/16,00:30:30.1) DSN (43).
DELETE (F2MF3) BAND (X) AT (90/08/16,14:54:30.0) DSN (65).
DELETE (F2MF3) BAND (X) AT (90/08/16,14:56:30.0) DSN (65).
DELETE (F2MF3) BAND (X) AT (90/08/16,15:00:30.0) DSN (65).

Fig. 12. Text file of delete commands.
Fig. 13. Lasso feature in workstation environment.
Fig. 14. Change Plot Scale dialog box.
Fig. 15. Magnifying glass feature for Ulysses residuals.